Саша Москалюк комментирует выход новой

Саша Москалюк комментирует выход новой версии Firebird.
Должен сказать, я не тороплюсь себе обновлять используемый 0.7RC — не вижу смысла, вряд ли за неделю там много чего изменилось.
Вот с этим соглашусь на все 100%:

Как выяснилось по окончанию загрузки, новый броузер еще и не обязательно поддерживает старые темы, т.е. что-то, конечно, поддерживается, но привычной Luna Blue в их списке нет, и пока приходится пользоваться неудобным скином по умолчанию. Скорей всего по нeбoскребу Mozilla Foundation ходит некий программист не у дел, и перед самым релизом предлагает что-то типа «Да, отличная у нас программа и все работает, но давайте мы отменим совместимость со скинами предыдущих версий» и все соглашаются «Да, действительно, ведь скины — это такой высокотехнологический продукт, что поддерживать их при переходе с версии 0.6 на версию 0.7 мы просто не в состоянии».

Вообще говоря, Luna Blue можно натянуть на новый релиз — ставится Themer, который позволяет ставить любую ранее скачанную тему, и это решает проблему. Но только отчасти — ибо полная совместимость между скинами в различных версиях действительно отсутствует. Я, кстати, именно об этом писал — если Luna Blue натянуть на Firebird 0.7, из него моментом исчезают полоса прокрутки и отказываются работать выпадающие меню. У меня, откровенно говоря, такое в голове не укладывается — как же так, проклинаемая всеми Windows спокойно отрабатывает все вариации, которые только могут придти в голову, и правильно написанная программа для Windows 3.1 спокойно работает хоть и на XP, хотя между ними более 10 лет бурной эволюции. А три месяца эволюции программы в мире open-source приводят к потере совместимости в таких мелочах.
Впрочем, стоит отметить, что эта самая поддержка скинов в Mozilla сделана так криво, что таким фокусам не приходится удивляться. Несмотря на декларативную кросс-платформенность, мне так и не удалось добиться одинакового вида Mozilla в Windows и Linux. В половине случаев, список тем для Linux абсолютно не совпадает с аналогичным для Windows, а, даже если что-то и совпадает, сайт радостно сообщает — «Вы используете 1.4, это тема для 1.4, но файла темы для вашей версии нет».
Чудеса да и только…

Прокомментировать:

avatar
  Subscribe  
Сообщать