Немного отвлечемся от политики. Последние

Немного отвлечемся от политики.
Последние несколько дней я резко сменил предпочтения в части использования броузеров и начал пользоваться в основном Firebird`ом (теперь Firefox). На удивление, Firefox оказался действительно удобен и почти без приколов, свойственных этой ветке броузеров ранее. Впрочем, свои грабли он все же раскладывает.
Начнем с того, что видно сразу — скоро меня будет удивлять совместимость тем и расширений между различными builds. Это фантастика — примерно половина тем, которые подходили для версии 0.6, просто не видны в версии 0.8, а из остальных примерно 60% не устанавливается. Вот не ставится и все тут. Тоже самое — с расширениями. Расширения, прекрасно ставящиеся на 0.7 и даже на 0.8.0+ (custom builds), не желают ставиться на официальный релиз 0.8. Опять начнутся разговоры о новом, прогрессивном движке — по сути, являющиеся болтовней с целью прикрыть неряшливость разработчиков. Вдумайтесь — если они не в силах обеспечить совместимость расширений между 0.7 и 0.8 (а раньше аналогичная ситуация наблюдалась при переходе с 0.6 на 0.7), то что нас ждет при переходе с версии 1.0 на 2.0? Впрочем, до этого еще жить и жить.
Определенно удачная мысль разработчиков — сделать, наконец, инсталлер. Не прошло и года, так сказать. На удивление, новая установка подхватила профиль пользователя, сделанный для FireBird и подключила некоторые расширения. Впрочем, не все.
О смене названия я уже говорил. Глупость это. Как верно заметили на Слэшдоте, почему бы им каждый билд не обзывать по-новому.
Но в целом — уже можно пользоваться. Закрывая, разумеется, глаза на всякие open-source фокусы.

Прокомментировать:

avatar
  Subscribe  
Сообщать